The PresenZ Dashboard

A. The workspace

Here you will be able to manage your Prz images. You can easily drag and drop your Prz files or previous created Prz lists. Alternatively you can navigate to the menu File>Import to do the same.

B. Menu bar.

File

  • File->New (Ctrl + N): Start a new przlist project.
  • File->Open (Ctrl + O): Open an existing przlist file.
  • File->Import (Ctrl + I): Import prz or przlist files.
  • File->Save (Ctrl + S): Save current project.
  • File->Save As: Save current project as a new przlist file.
  • File->Create Package: Copy and save all the files in a single folder and generate a przlist with relative paths.
  • File->Exit (Ctrl + Q): Exit the dashboard.

Edit

  • Edit->Undo (Ctrl + Z): Undo last action.
  • Edit->Redo (Ctrl + Y): Redo last action.
  • Edit->Create multibox from selection (Ctrl + M): When you have 2 or more prz files selected, these will be merged into a multibox prz file.
  • Edit->Select All (Ctrl + A): Select all files.
  • Edit->Delete Selected (Del): Delete all selected files.
  • Edit->Update Image image (Ctrl+U): Will update the current prz image, keeping all the current settings and teleport points.
  • Edit->Settings: Open the settings window.

Edit->Settings

../_images/Settings.PNG
  • Check/Uncheck Launch viewer application on start: if checked will launch the viewer in desktop mode or VR mode when launching the dashboard.
  • Check/Uncheck Force multibox display: if checked will force the multibox grid to be on eventhough the prz files are in position 0,0,0.

Multibox

  • Multibox->Create multibox from selection (Ctrl + M): Will merge zones of view into a multibox setup. For more information scroll down to F. Multibox setup grid.

Teleport

  • Teleport->Edit teleport points (Ctrl + T): Will allow you to edit the teleport points of the selected image. Displayed by a T on the thumbnail.
  • Teleport->Copy teleport points (Ctrl + Shift + C): Will copy the teleport points of the current image you are editing.
  • Teleport->Paste teleport points (Ctrl + Shift + V): Will paste the teleport points of the current image you are editing.

Watermark

For a more detailed explanation on how to remove your watermark please refer to the watermark section of the documentation.

  • Watermark->Remove All: Will remove all the watermarks in your current dashboard project.
  • Watermark->Remove Selected: Will remove the watermark of the selected prz files.

Help

  • Help->Dashboard help: Will open a browser with the documentation on the PresenZ dashboard.
  • Help->License request information: Will display the UUID of the computer which the dashboard is installed on. We will need this information to generate a license.
  • Help->Check for update.. : Will check for the latest dashboard/viewer version and update if found.

C. PresenZ Viewer and play controls.

You can launch the viewer in two different ways:

  • Desktop Mode: This does not require virtual reality headset to play. You can simply view the prz files on your desktop.
  • VR Mode: This will launch PresenZ in VR mode, will require a headset and SteamVR to be installed.

Once inside the viewer you will be able to use the play controls menu.

  • Previous/next: Will cycle you through the prz files. You can also simply click the file you want to see, without particalur order.
  • Check/uncheck slideshow: Will cycle through your prz project with an interval of the chosen seconds.
  • Volume Slider: You can control the volume for the audio with this slider. Only active once the Viewer is launched.
  • Reset Height: Resets the vertical position to the default height. We recommend to do this for every different individual so that the person is in the center of the box.
  • Reset View: Resets the horizontal position to the start. We recommend to do this for every different individual so that the person is in the center of the box.
  • Glow (global): By default 1.00 . Will increase the glow on all your prz files in the project.
  • Check/uncheck Display the ZOV when free roaming: When using the free roam feature this will display the ZOV boundaries in your scene.

D. Prz file image parameters.

These parameters apply for the selected prz files.

  • Check/uncheck Free roam: Allows the user to walk freely inside the scene. Breaking the boundaries of the ZOV. The geometry that is missing from the render will be filled in by blurring the closest matching color.
  • Check/uncheck: Override global glow: Will override the global glow setting for the selected prz files to the desired value.
  • Image glow: By default 1.00, this will change the glow amount of the selected prz files.
  • Default Rotation: Overrides the default rotation of the selected prz files. Helpful to pick a specific point of interest for the viewer in your prz file.
  • Background Rotation: Rotates your background image. Helpful to match your orientation of the skydome in your 3d program.
  • Compute and embed the background mask: This will generate a background mask and embed it in your prz file. Only to be used if you do not use a skydome. For more information on the subject you can refer to the utilities background mask section.
  • Edit Background Image: You can select a background image. If you used the presenz_merger_UI.exe and merged a background image there, it will overwrite the previous background image.

E. Sound Parameters.

Here you can set an audio file bound to a specific single prz image. Every prz image has its own settings.

  • Load Sound: Select an audio files with the .tbe or .opus file format.
  • Remove Sound: Remove the selected audio files.
  • Check/uncheck Loop Sound: Will loop the sound indefinitely.
  • Check/uncheck Autonext when the sound is over: When checked this will go to the next image once the audio file is done playing.

F. Multibox setup grid.

For more information on the concept of the multibox the multibox section in the general information.

The multibox grid will only be visible if you have a prz file selected where the zone of view is not in position x0,y0,z0. You can force the multibox grid to be active at all times in the edit>settings menu.

For this demostration I will assume that you have went through the process off rendering out multiple zones of view, and now you wish to add them together for one scene.

../_images/Multibox.PNG
  • In the image above you can see that I have selected 3 different prz files. Each of which have a different location inside the Multibox grid visualisation.
  • After I am satisfied with my selection I will merge them together by going to Edit>Create multibox from selection (Ctrl + M).
  • Once the merge is done you will see only one prz file with an M icon for multibox, and also see all the zones of view in this file.
../_images/MultiboxMerge.PNG ../_images/MultiboxViewer.PNG
  • If you made a mistake, or wish to change something at a later date, you can simply drag and drop the desired zone of view back to the project.

G. Edit teleport points window.

There is a video in the tutorial section that explain step by step how to set up a teleporter.

  • You can drag and drop other prz files you wish to link to the current editing prz file in this section.
  • The current file you are editing is marked with T on the thumbnail. When changing between prz files the T for edit mode will remain on that file until you press “edit teleport points (Ctrl+T)” from the menu again and see the T in the thumbnail change to a new prz file.
  • You can press the “start editing link in VR” if you have “VR mode” open. Ideally you will not use this button, but rather use the way to edit points from within the headset, using a controller. This way you don’t have to keep swapping from computer screen to VR headset.
  • Once you have some points edited, the information about those points will be displayed here. The position, icon, size, color are displayed here. when copy/pasting this is the information that will be copied, not the file itself.
../_images/TeleportPoints.PNG
  • Update your prz file by using Edit->Update Image (Ctrl +U). This will keep all your teleport information, but changes the prz file. Handy for when you want to insert a new itteration of your PresenZ render.